Back to overview
Resolved

Scheduled maintenance at our datacenter

Jun 17, 2026 at 2:10am UTC  –  Jun 17, 2026 at 2:30am UTC
Affected services
Core Services
Supporting Services

Resolved
Jun 17, 2026 at 2:30am UTC

Maintenance ended

Created
Jun 17, 2026 at 2:10am UTC

This morning, scheduled maintenance was performed at our datacenter. The work took place around 04:10 to 04:30 CEST on June 17, 2026, and users may have noticed brief interruptions during this time.

Everything is back to normal now, and all services are running as expected. We appreciate your understanding.