Back to overview
Degraded

Backend performance degradation

Oct 21 at 04:31pm CEST
Affected services
Core Services
Supporting Services

Resolved
Oct 21 at 04:52pm CEST

Performance has stabilized and response times are back to normal.

Created
Oct 21 at 04:31pm CEST

We’re currently experiencing degraded performance in our backend systems. Some requests may be slower than usual or fail entirely. Our team is actively investigating and working to restore full service.